zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1326题(Box of Bricks) 的理解(C/C++)

2019-08-19 hdoj cout输出格式 简单题 Southwestern Europe 1997
Word count: 599 | Reading time: 3min


    注意要求是每个set案例后要多输出一个空白行。而且题目貌似没交代重点,只能一个箱子一个箱子地搬(但实际上确实这样的)。


就给的示例可以看出,如果可以一次搬多个箱子,那么先从7搬3个到1的位置,然后各搬2个5的其中1个箱子到2的位置,总共应该是3步才对,但是示例答案确实给的5.所以–>一次只能搬一个箱子。





Box of Bricks(搬箱子)

Box of Bricks
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description
    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I’ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

示例图

Input
    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output
    For each set, first print the number of the set, as shown in the sample output. Then print the line “The minimum number of moves is k.”, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height .

Output a blank line after each set.

Sample Input
6
5 2 4 1 7 5
0

Sample Output
Set #1
The minimum number of moves is 5.

Source

    Southwestern Europe 1997




原题链接

More info:Question


Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include<iostream>

using namespace std;
int a[51],t;
int main() {
int set = 0;
while (cin >> t) {
if (t == 0) break;

int sum = 0;
for (int i = 0; i < t; i++) {
cin >> a[i];
sum += a[i];
}
int average = sum / t;
sum = 0;
for (int i = 0; i < t; i++) {
if (a[i] < average)sum += (average-a[i]);
}
set++;
cout << "Set #" << set << endl;
cout << "The minimum number of moves is " << sum << "." << endl << endl;
}
return 0;
}

参考博客

博主 AI圈终身学习 的ACM水题系列 HDOJ 1326

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/19/hdoj1326/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1330题(Deck) 的理解(C/C++)
NextPost >
使用git提交本地文件夹到github仓库
CATALOG
  1. 1. Box of Bricks(搬箱子)
  2. 2. 原题链接
  3. 3. Accepted代码
  4. 4. 参考博客