zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1303题(Doubles 双倍) 的理解(C/C++)

2019-08-18 hdoj 简单题 Mid-Central USA 2003
Word count: 411 | Reading time: 2min


    水题。









题目描述:Doubles(双倍)

TDoubles
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description
    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input
    The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output
    The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output
3
2
0

Source

    Mid-Central USA 2003



原题链接

More info:Question




Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include<iostream>
#include<algorithm>
using namespace std;

int a[16], count_;
int main() {
while (1) {
int x;
cin >> x;
if (x == -1)break;

a[0] = x; count_ = 0; int n = 1;
for (int i = 1; i < 16; i++) {
int y;
cin >> y;
if (!y) break;
a[i]=y;
n++;
}
sort(a, a+n);
for (int i = 0; i < n; i++) {
for (int j = 0; j < i; j++) {
if (a[i] == 2 * a[j]) {
count_++;
}
}
}
cout << count_ << endl;
}
return 0;
}

参考博客

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/18/hdoj1303/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1323题(Perfection) 的理解(C/C++)
NextPost >
关于HDOJ 1302题(The Snail 蜗牛爬井) 的理解(C/C++)
CATALOG
  1. 1. 题目描述:Doubles(双倍)
  2. 2. 原题链接
  3. 3. Accepted代码
  4. 4. 参考博客