zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1302题(The Snail 蜗牛爬井) 的理解(C/C++)

2019-08-18 hdoj 简单题 Mid-Central USA 1997
Word count: 772 | Reading time: 4min


    简单题。

  1. 首先注意一下数据类型,应该是double型,别习惯性地敲成int了;
  2. 然后是如果蜗牛头天晚上恰好跌倒井底,那么算第二天的失败,不能算在头天上(我也不知道为啥,但是从给的第二组数据来看应该是这样的)
  3. 最后如果能成功,必须是爬出井口,也就是说当前位置必须严格大于井的深度,不可取等



题目描述:The Snail(蜗牛爬井)

The Snail
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description
    A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day’s climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail’s height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.

Day Initial Height Distance Climbed Height After Climbing Height After Sliding
1 0 3 3 2
2 2 2.7 4.7 3.7
3 3.7 2.4 6.1 -

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail’s height will exceed the height of the well or become negative.) You must find out which happens first and on what day.

Input
    The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail’s climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.

Output
    For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input
6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output
success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2

Source

    Mid-Central USA 1997



原题链接

More info:Question




Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include<iostream>
#include<string>
using namespace std;

double H, U, D, F;
int main() {
while (cin >> H >> U >> D >> F) {
if (!H && !D && !U && !F) break;

int count = 0;
double f = (U * F / 100), h = H;
string res;
while (1) {
count++;
H -= U;
if (H < 0) {
res = "success ";
break;
}
H += D;
if (U - f >= 0) U -= f;
else U = 0;
if (H >= h && count != 1) {
if (H == h) count++;
res = "failure ";
break;
}
}
cout << res+"on day " <<count << endl;
}
return 0;
}

参考博客

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/18/hdoj1302/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1303题(Doubles 双倍) 的理解(C/C++)
NextPost >
关于HDOJ 1283题(最简单的计算机) 的理解(C/C++)
CATALOG
  1. 1. 题目描述:The Snail(蜗牛爬井)
  2. 2. 原题链接
  3. 3. Accepted代码
  4. 4. 参考博客