zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1236题(排名) 的理解(C/C++)

2019-08-12 hdoj 统计 浙大计算机研究生复试上机考试-2005年
Word count: 795 | Reading time: 3min

    简单题,但是还是没有一次A过。有3点,其中2个粗心点在AC代码中备注出来了,另外一点是因为审题不仔细漏看了一点——“若有多名考生分数相同,则按他们考 号的升序输出”,在cmp函数中多加这一条件后AC了……




题目描述:排名

排名
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description
    
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。

Input
    测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理

Output
    对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。

Sample Input
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

Sample Output
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

Hint

Huge input, scanf is recommended.

Author
    Ignatius.L

Source
    浙大计算机研究生复试上机考试-2005年

原题链接

More info:Question

Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include<iostream>
#include<algorithm>
#include<string> //这里开始忘记加头文件编译错误
using namespace std;

const int maxn = 1001;
typedef struct node {
string nameId;
int solNum;
int qNum[10];
int res;
};
node stu[maxn];
int students, questions, grades;
int q_grade[10];
bool cmp(node& a, node& b) {
if (a.res != b.res)return (a.res > b.res ? true : false);
else return(a.nameId<b.nameId? true:false);
}
int main()
{
while (cin >> students) {
if (students == 0) break;

cin >> questions>>grades;
for (int i = 0; i < questions; i++) cin >> q_grade[i];
for (int i = 0; i < students; i++) {
cin >> stu[i].nameId >> stu[i].solNum;
for (int j = 0; j < stu[i].solNum; j++) cin >> stu[i].qNum[j];
}


for (int i = 0; i < students; i++) {
stu[i].res = 0;
for (int k = 0; k < stu[i].solNum; k++) {
stu[i].res += (q_grade[stu[i].qNum[k]-1]); //这里忘记要-1,结果res(分数)的计算出错
}
}
sort(stu, stu + students, cmp);

int count = 0;
for (int i = 0; i < students; i++) {
if (stu[i].res >= grades)count++;
}

cout << count << endl;
for (int i = 0; i < count; i++) cout << stu[i].nameId << " " << stu[i].res<<endl;
}
return 0;
}

参考博客

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/12/hdoj1236/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
Android通过Jdbc直接连接本地MySQL数据库
NextPost >
关于HDOJ 1235题(统计同成绩学生人数) 的理解(C/C++)
CATALOG
  1. 1. 题目描述:排名
  2. 2. 原题链接
  3. 3. Accepted代码
  4. 4. 参考博客