zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1196题(Lowest Bit(最低位数)) 的理解(C/C++)

2019-08-09 hdoj 思路 进制转换 Zhejiang University Local Contest 2005
Word count: 286 | Reading time: 1min

题目描述

                                              Lowest Bit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15618 Accepted Submission(s): 11170

Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.

Sample Input
26
88
0

Sample Output
2
8

Author
SHI, Xiaohan

Source
Zhejiang University Local Contest 2005


原题链接

More info:Question


## Accepted代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int n;
int main() {
while (cin >> n) {
if (n == 0)break;
int m = 1;
while (n % 2 == 0) {
n /= 2;
m *= 2;
}
cout << m << endl;
}
return 0;
}







Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/09/hdoj1196/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1197题(进制转换) 的理解(C/C++)
NextPost >
关于HDOJ 1157题(Who's in the Middle(中位数)) 的理解(C/C++)
CATALOG
  1. 1. 题目描述
  2. 2. 原题链接