zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1058题(Humble Numbers(有且仅有质因数2,3,5,7组成的数)) 的理解(C/C++)

2019-08-09 hdoj 因数分解
Word count: 707 | Reading time: 4min

题目描述

                       Humble Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 32500 Accepted Submission(s): 14198

Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output
    For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source
    University of Ulm Local Contest 1996

原题链接

More info:Question

Accepted代码

重写min函数,用min()来判断4个参数中最小的一个,并且把对应的计数器自加1。然后从2到5842遍历一遍所有的符合要求的Humble Numbers,存进f[]数组中。

核心在于:

f[t] = min(2 * f[i], 3 * f[j], 5 * f[k], 7 * f[l]);

int min(int a, int b, int c, int d)
{
int min = a;
if (b < min) min = b;
if (c < min) min = c;
if (d < min) min = d;

if (a == min) i++;
if (b == min) j++;
if (c == min) k++;
if (d == min) l++;

return min;

}


最后的几句if用于判断n后应该跟st还是nd还是th:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <iostream>
#include <stdio.h>
using namespace std;
int f[5843], n;
int i, j, k, l;

int min(int a, int b, int c, int d)
{
int min = a;
if (b < min) min = b;
if (c < min) min = c;
if (d < min) min = d;

if (a == min) i++;
if (b == min) j++;
if (c == min) k++;
if (d == min) l++;

return min;
}

int main()
{
i = j = k = l = 1;
f[1] = 1;
for (int t = 2; t <= 5842; t++)
{
f[t] = min(2 * f[i], 3 * f[j], 5 * f[k], 7 * f[l]);
}
while (cin>>n && n != 0)
{
if (n % 10 == 1 && n % 100 != 11)
cout << "The " << n << "st humble number is " << f[n] << "." << endl;
else if (n % 10 == 2 && n % 100 != 12)
cout << "The " << n << "nd humble number is " << f[n] << "." << endl;
else if (n % 10 == 3 && n % 100 != 13)
cout << "The " << n << "rd humble number is " << f[n] << "." << endl;
else
cout << "The " << n << "th humble number is " << f[n] << "." << endl;
}

return 0;
}

参考博客

非常感谢寻找小海螺的博文

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/09/hdoj1058/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1076题(An Easy Task(x后第n个闰年)) 的理解(C/C++)
NextPost >
关于HDOJ 1048题(The Hardest Problem Ever) 的理解(C/C++)
CATALOG
  1. 1. 题目描述
  2. 2. 原题链接
  3. 3. Accepted代码
  4. 4. 参考博客