zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1019题(Least Common Multiple)的理解(C/C++)

2019-08-09 hdoj 粗心
Word count: 545 | Reading time: 3min

    主要是循环体内的小细节问题,为了对比突出一点,把WA和AC的代码就一起贴出来啦(虽然感觉有点像鞭尸……),详见代码

题目描述

A Mathematical Curiosity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53959 Accepted Submission(s): 17539

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input
1

10 1
20 3
30 4
0 0

Sample Output
Case 1: 2
Case 2: 4
Case 3: 5

Source
East Central North America 1999, Practice

Source
South Central USA 1996

原题链接

More info:Question

Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include<iostream>

using namespace std;
int max_gys(int a, int b) {
if (b == 0) return a;

return ( max_gys(b,a%b) );
}

int main() {
int N;
cin >> N;
while (N--) {
int n;
cin >> n;
int a, b;
cin >> a ;
while (--n) {
cin >> b;
a = b / max_gys(a, b) *a;
}
cout << a << endl;
}
return 0;
}

TLE代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include<iostream>

using namespace std;
int max_gys(int a, int b) {
if (b == 0) return a;
return ( max_gys(b, a % b) );
}
int min_gbs(int a, int b) {
return (a * b / max_gys(a, b));
}
int main() {
int N;
cin >> N;
while (N--) {
int n;
cin >> n;
int a, b;
cin >> a >> b;
while (--n) {
a = min_gbs(a, b);
if (n == 1) break;//主要就是这,当天肯定脑壳不清醒
cin >> b;
}
cout << a << endl;
}
return 0;
}

总结

当天肯定是头晕着做的题,(……),就是循环体内的循环不明确,导致个别特殊的情况输入时,一直没有输出导致的超时。以后一定注意!!

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/09/hdoj1019/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1021题(Fibonacci Again) 的理解(C/C++)
NextPost >
关于HDOJ 1017题(A Mathematical Curiosity)的理解(C/C++)
CATALOG
  1. 1. 题目描述
  2. 2. 原题链接
  3. 3. Accepted代码
  4. 4. TLE代码
  5. 5. 总结