zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1017题(A Mathematical Curiosity)的理解(C/C++)

2019-08-09 hdoj
Word count: 444 | Reading time: 2min

    该题直接循环就行了,没有超时超限的顾虑。只是最开始案例输入的那个1我没看懂是啥意思
读了下别人的代码之后懂了,那个最开始输入的整数是表示有几大组数据的意思,详见代码

题目描述

A Mathematical Curiosity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53959 Accepted Submission(s): 17539

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input
1

10 1
20 3
30 4
0 0

Sample Output
Case 1: 2
Case 2: 4
Case 3: 5

Source
East Central North America 1999, Practice

Source
South Central USA 1996

原题链接

More info:Question

Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include<iostream>

using namespace std;

int main() {
int n, m;
int num;
int no=1;
int N;
cin >> N;
while (N--) {
no = 1;
while (cin >> n >> m) {
num = 0;
if (n == 0 && m == 0) break;
int a, b;
for (b = 1; b < n; b++) {
for (a = 1; a < b; a++) {
if ((a * a + b * b + m) % (a * b) == 0) {
num++;
}
}
}
cout << "Case " << no << ": " << num << endl;
no++;
}
if (N != 0) cout << endl;
}

return 0;
}

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/09/hdoj1017/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1019题(Least Common Multiple)的理解(C/C++)
NextPost >
关于HDOJ 1014题(Uniform Generator)的理解(C/C++)
CATALOG
  1. 1. 题目描述
  2. 2. 原题链接
  3. 3. Accepted代码