zoey
点击国内主页可以让浏览速度加快哦 ~ !

关于HDOJ 1014题(Uniform Generator)的理解(C/C++)

2019-08-09 hdoj cout输出格式
Word count: 875 | Reading time: 4min

    本题主要思路为,用while循环进行标记,如果seed()方法中被遍历过的数,则吧对应的flag[ ]设置为1,同时通过不断更新下一个seed数,并以flag[ seed ]为终止条件即可,同时在循环体内用count记一下数,count=mod则说明是good chioce(反之相反),详见AC代码。

题目描述

Uniform Generator
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37373 Accepted Submission(s): 14842

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5
15 20
63923 99999

Sample Output
3 5 Good Choice

   15        20    Bad Choice

63923     99999    Good Choice

Source
South Central USA 1996

原题链接

More info:Question

cout输出位数控制———整体输出位数的控制

通过setw(n)方法设置下一个输出量时,设定输出的长宽为n个字符。输出量不达n个字符时,会在输出量左边填补对应的空白;若宽于n个字符,则按实际需要全部输出:

1
2
3
4
5
6
7
8
9
10
11
 #include<iostream>
#include<iomanip>
using namespace std;
int n;
int main() {
while (cin >> n) {
if (n == -1) break;
cout << setw(5)<<n << endl;
}
return 0;
}

运行结果示意:
运行结果示意

cout靠左或者靠右输出的设置

1
2
3
4
5
6
//默认是右对齐.
cout <<left ; // 左对齐
cout <<setw(5) <<12 <<setw(5) <<34 <<endl ; // 12___34___

cout <<right ; // 默认 右对齐
cout <<setw(5) <<12 <<setw(5) <<34 <<endl ; // ___12___34

Accepted代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include<iostream>
#include<iomanip>
#include<cstring>
using namespace std;
int flag[100001];
int main() {
int step, mod,count;
while (cin >> step >> mod) {
memset(flag, 0, sizeof(flag));
count = 0;
int seed = 0;
while (!flag[seed]) {
flag[seed] = 1;
seed = (seed + step) % mod;
count++;
}
if (count == mod) cout << right << setw(10) << step << setw(10) << mod << " " << left << "Good Choice" << endl << endl;
else cout << right << setw(10) << step << setw(10) << mod << " " << left << "Bad Choice" << endl << endl;
}

return 0;
}

Author: Zoey

Link: https://zoey1038569979.github.io/2019/08/09/hdoj1014_blog/

Copyright: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.

< PreviousPost
关于HDOJ 1017题(A Mathematical Curiosity)的理解(C/C++)
NextPost >
调整hexo博客下markdowm的内容中的图片大小
CATALOG
  1. 1. 题目描述
  2. 2. 原题链接
  3. 3. cout输出位数控制———整体输出位数的控制
  4. 4. cout靠左或者靠右输出的设置
  5. 5. Accepted代码